أنت هنا

صدور تحديث للغة php 5.4.17

الكاتب : شبيب ال مطلق | 07/09/2013 |

بسم الله الرحمن الرحيم وبه نستعين...

في خطوه غريبه تم اصدار تحديث يتيم للغة برمجة المواقع php الاصدار الحديث منها 5.4.17 مخصص لها وتم خلالها اصلاح الاخطاء الموجوده في الاصدار السابقه وهنا الاخطاء بالتفصيل

اخطاء قلب اللغه =

Core:

  • Fixed bug #64988 (Class loading order affects E_STRICT warning).
  • Fixed bug #64966 (segfault in zend_do_fcall_common_helper_SPEC).
  • Fixed bug #64960 (Segfault in gc_zval_possible_root).
  • Fixed bug #64936 (doc comments picked up from previous scanner run).
  • Fixed bug #64934 (Apache2 TS crash with get_browser()).
  • Fixed bug #64166 (quoted-printable-encode stream filter incorrectly discarding whitespace).

وهذي بقية الاخطاء في المكتبات التابعه للغه =

  • DateTime:
    • Fixed bug #53437 (Crash when using unserialized DatePeriod instance).
  • FPM:
    • Fixed bug #64915 (error_log ignored when daemonize=0).
    • Implemented FR #64764 (add support for FPM init.d script).
  • PDO:
    • Fixed bug #63176 (Segmentation fault when instantiate 2 persistent PDO to the same db server).
  • PDO_DBlib:
    • Fixed bug #63638 (Cannot connect to SQL Server 2008 with PDO dblib).
    • Fixed bug #64338 (pdo_dblib can't connect to Azure SQL).
    • Fixed bug #64808 (FreeTDS PDO getColumnMeta on a prepared but not executed statement crashes).
  • PDO_firebird:
    • Fixed bug #64037 (Firebird return wrong value for numeric field).
    • Fixed bug #62024 (Cannot insert second row with null using parametrized query).
  • PDO_mysql:
    • Fixed bug #48724 (getColumnMeta() doesn't return native_type for BIT, TINYINT and YEAR).
  • PDO_pgsql:
    • Fixed bug #64949 (Buffer overflow in _pdo_pgsql_error).
  • pgsql:
    • Fixed bug #64609 (pg_convert enum type support).
  • Readline:
    • Implement FR #55694 (Expose additional readline variable to prevent default filename completion).
  • SPL:
    • Fixed bug #64997 (Segfault while using RecursiveIteratorIterator on 64-bits systems).

الغريب يا احباب تم اصدار هذه النسخه وحيده بدون الجيل السابقه 5.3 وهذا دليل اما على استقرار الجيل السابقه او توقف اصدار التحديثات لها وهذا اكبر دليل يا احباب على وجوب الانتقال الى الاصدار الحديث خاصه المبرمجين واصحاب المواقع لابد من الآن تحديث سكربتاتكم واعتقد غالبية السكربتات المدفوعه او المجانيه ذات الدعم الجيد تم ترقيتها لتعمل على الاصدار 5.4 بدون مشاكل ...

هذا وصلى الله وسلم على نبينا وسيدنا محمد صلى الله عليه واله وصحبه وسلم تسليماً كثيراً...

القسم :

Tags: